Problemas com Legenda Externa.

juliopedroni
Ensign
Ensign
Posts: 2
Joined: 08 Mar 2017, 14:07
TV Model: Samsung
Been thanked: 1 time
Flag: Brazil

Problemas com Legenda Externa.

Postby juliopedroni » 08 Mar 2017, 14:39

Bom dia pessoal,
Estou utilizando uma playlist externa no SSIPTV e estou enfrentando problemas com caracteres especiais:
Acentuação, cedilha, quebra de linha, etc. Segue abaixo informações:

Playlist:
#EXTM3U
#EXTINF:-1 tvg-id="Filme" tvg-name="Filme" subtitles="http://192.168.25.10/iptv/Filme.srt" aspect-ratio="original",Filme
http://192.168.25.10/iptv/Filme.mkv

Legenda:
00:01:31,599 --> 00:01:35,673
<i>Eu pensava que este era o começo
da sua história.</i>

Resultado esperado:
Eu pensava que este era o começo
da sua história.

Resultado:
Eu pensava que este era o comeo da sua histria.

Como vocês podem reparar:
1 - Não ocorreu a quebra de linha;
2 - Removeu o caracter "ç" da palavra "começo", apresentando errado: comeo;
3 - Removeu o caracter "ó" da palavra "história", apresentando errado: histria;

Tentativas de solução:
1 - Trocar a codificação do arquivo .srt para ANSI;
2 - Trocar a codificação do arquivo .srt para UTF-8;
3 - Trocar no meu servidor para entregar arquivos .srt com a codificação UTF-8;

Minhas perguntas aos amigos do fórum são:
1 - Existe alguma forma de resolver o problema dos caracteres especiais?
2 - Existe alguma forma de resolver o problema da quebra de linha?
3 - O SSIPTV aceita algum outro tipo de legenda externa que não seja .srt?

Pergunta adicional:
Atualmente, meu servidor local (que utilizo como externo no SSIPTV) está rodando como aplicativo no IIS.
Existe algum software melhor indicado para a criação de um servidor local e que possa vir a resolver os problemas da legenda?

Em anexo coloquei a playlist e a legenda (renomear para .srt) para avaliação.
Desde já agradeço pela ajuda!
Abração!

User avatar
Guigo
Captain
Captain
Posts: 150
Joined: 31 Mar 2017, 11:45
TV Model: Samsung Smart TV J4300
Been thanked: 67 times
Flag: Brazil

Re: Problemas com Legenda Externa.

Postby Guigo » 05 Apr 2017, 20:36

Então eu recomendo utilizar esse site ele não vai apagar a letra e sim substituir
http://www.aquifolium.com/removedor-de-acentos.html

acentos na letra é ele deixa e'
ç fica c.

Peguei o seu exemplo e veja como ficou

Legenda:
00:01:31,599 --> 00:01:35,673
<i>Eu pensava que este era o começo
da sua história.</i>

Resultado esperado:
Eu pensava que este era o começo
da sua história.

Resultado:
Eu pensava que este era o comeco
da sua historia.

User avatar
5kyb0y
Ensign
Ensign
Posts: 4
Joined: 21 Apr 2017, 03:16
TV Model: SAMSUNG LG SONY
Been thanked: 1 time
Flag: Brazil

Re: Problemas com Legenda Externa.

Postby 5kyb0y » 21 Apr 2017, 03:42

Juliio, eu tive um problema parecido com o seu, quando tentei fundir uma legenda a um filme.

Era até um problema muito estranho, pois, quando eu rodava o filme pelo VLC Player a legenda saia certinho com acentuações e tudo, porém quando eu tentava fundir a legenda utilizando o FormatFactory, os acentos e Ç ç eram trocados por caracteres estranhos.

Resolvi da seguinte forma:

1 - Abri o arquivo .srt no editor notepad++ ;
2 - Fui em Menu--> Formatar --> Converter para ANSI;
3 - Após, Menu ---> Arquivo --> Salvar Como ...
3.1 - No campo Nome vc mantém o mesmo nome e no final vc coloca .srt (ex.: NomeFilme.srt), e no campo Tipo: vc coloca *.*
4 - Só Clicar em salvar.

Pra mim deu certo, acredito que com o Stream tbm dê certo.

Espero ter ajudado

[]s

5kyb0y


Return to “SS IPTV Forum Português”

Who is online

Users browsing this forum: No registered users and 2 guests