Page 1 of 1

Subtitles

Posted: 16 Feb 2020, 23:48
by mav
First of all. Thank you for this IPTV app. In my opinion it is the best available for LG TV!

I just have a minor issue. But it would be nice if somebody could come up with a solution.

I use the IPTV sources from my TV provider. Some channels offer a subtitle track in the options. The first one seems to be a track for the hearing impaired. The strange thing is that if subtitles available the subtitles are always displayed. Is there a way to prevent this? As a workaround I found out that if I change the subtitle language twice (e.g. from hearing impaired to German and then back to hearing impaired) the subtitle disappears again.

Can I control this somehow via the M3U list? Currently an entry looks like this.

#EXTINF:-1,Channel One
udp://@239.77.0.77:5000

Re: Subtitles

Posted: 18 Feb 2020, 12:17
by admin
Hi,

The root cause is not clear for us.
We will try to reproduce the issue on our side to get details.

You may try to use #EXTINF attribute subtitles, as in examples:

Code: Select all

#EXTINF:-1 subtitles="000" ,Channel One
udp://@239.77.0.77:5000


Code: Select all

#EXTINF:-1 subtitles="fra" ,Channel One
udp://@239.77.0.77:5000

Re: Subtitles

Posted: 21 Feb 2020, 21:21
by mav
I'm afraid that doesn't work. The subtitles are unfortunately still displayed initially.

If I can provide any additional information or data please let me know. If helpful I can also record parts of a stream and make them available. Thanks!

Re: Subtitles

Posted: 22 Feb 2020, 02:40
by Eugene
Sure, it would be useful.

Re: Subtitles

Posted: 23 Feb 2020, 12:27
by mav
OK. Let me know which additional information you need to be able to reproduce this issue. Can I record somehow the raw stream (e.g. using VLC or are there better tools)?

Re: Subtitles

Posted: 03 Mar 2020, 16:00
by admin
Hi,

Could you share stream example to support@ss-iptv.com?

Re: Subtitles

Posted: 12 Mar 2020, 22:46
by mav
Sample stream was sent ...

Re: Subtitles

Posted: 09 Jun 2020, 14:01
by longpol
Any news about this? Curiosly, I have recently bought my second LG smart tv and this is happenning to me too. On my old set (a model from 2019) subtitles are not displayed by default but on this new one tv they are indeed. Whenever I change channels subs are displayed if present, I go to options menu, select any language, go back to "switch off" and they are gone... until I change channels and go back. It's pretty annoying. :o

Re: Subtitles

Posted: 11 Jun 2020, 14:45
by Eugene
We know about this issue and will try to fix it in future.

Re: Subtitles

Posted: 11 Jun 2020, 15:00
by longpol
To put some light on this.

My "old" LG TV model 49UK6300PLB. No subs displayed by default. OK
My "new" LG TV model 43UM7100PLB. New webos interface.

As I said, subs are displayed by default if present on the stream on new LG TV. But only if subs are named "1: Español". If subs have another name like "1: 001" then they are not displayed by default. If subs have, ie, "1: 001" "2: Español" then I have to confirm what happens.

The only way to disable subtitles is to execute this sequence: off -> 1: Español -> off. It seems you have to force off subtitles to disable them. This is driving my crazy :geek:

I hope you get this fixed soon. Thanks.