Вроде всё готово, а каналы не грузит!

Обсуждение ошибок, помощь в решении проблем.
User avatar
Eugene
Project Leader
Project Leader
Posts: 5988
Joined: 15 Apr 2013, 22:54
TV Model: LG 47LM960V, LG LB679V
Location: Санкт-Петербург
Has thanked: 36 times
Been thanked: 248 times
Flag: Russia
Contact:

Re: Вроде всё готово, а каналы не грузит!

Postby Eugene » 11 Oct 2015, 20:28


alexk
Ensign
Ensign
Posts: 11
Joined: 10 Oct 2015, 11:11
Flag: Russia

Re: Вроде всё готово, а каналы не грузит!

Postby alexk » 12 Oct 2015, 19:34

Евгений, доброго времени суток!
По ссылке, дошёл до этого, но дальше не понимаю что делать..

Этот файл — стартовый скрипт udpxy. Подробнее о стартовых скриптах OpenWrt можно узнать здесь.
Содержимое нашего файла будет примерно таким:
#!/bin/sh /etc/rc.common
# Copyright (C) 2010 OpenWrt.org

START=99
STOP=10

IGMP_OPTS="-a br-lan -m eth1 -p 8888 -M 600"
IGMP_BIN="/usr/bin/udpxy"
PID_F="/var/run/udpxy.pid"

start() {
echo "Starting udpxy"
start-stop-daemon -S -x $IGMP_BIN -p $PID_F -b -m -- $IGMP_OPTS
}

stop() {
echo "Stopping udpxy"
start-stop-daemon -K -x $IGMP_BIN -q
}

Для запуска службы используется start-stop-daemon — утилита для контроля запуска и остановки системных служб. В IGMP_BIN указываем что и откуда запускать, PID_F — куда записать PID что бы в последствии за ним можно было следить, IGMP_OPTS — настройки запускаемой службы.

ВОПРОС:
Мне это длинное значение куда то надо вставить?! Я ввожу командлет "vi updxy" и появляется стартовый скрипт, а его исправлять или что?! И как?! Евгений если можно поподробней! По вебу я то настраивал много роутеров.. Но черерз консоль ниразу!

User avatar
Eugene
Project Leader
Project Leader
Posts: 5988
Joined: 15 Apr 2013, 22:54
TV Model: LG 47LM960V, LG LB679V
Location: Санкт-Петербург
Has thanked: 36 times
Been thanked: 248 times
Flag: Russia
Contact:

Re: Вроде всё готово, а каналы не грузит!

Postby Eugene » 12 Oct 2015, 19:49

Я, признаться, не специалист по сетевым устройствам и роутера tp-link у меня никогда не было. Так что, лично вам помочь не смогу.

alexk
Ensign
Ensign
Posts: 11
Joined: 10 Oct 2015, 11:11
Flag: Russia

Re: Вроде всё готово, а каналы не грузит!

Postby alexk » 16 Oct 2015, 08:18

Евгений спасибо большое за помощь в этом посте!
Всё заработало! Роутер tp-link Tl-wr941nd! Прошивка openwrt! Схема udp-http!

maksbaley
Ensign
Ensign
Posts: 4
Joined: 16 Sep 2015, 11:09

Re: Вроде всё готово, а каналы не грузит!

Postby maksbaley » 20 Nov 2015, 06:17

alexk wrote:Евгений спасибо большое за помощь в этом посте!
Всё заработало! Роутер tp-link Tl-wr941nd! Прошивка openwrt! Схема udp-http!

alexk я тоже поставил прошивку openwrt у Вас по вафле показывает, все сделал как в посту выше но так и не могу запустить кино. Что то еще допиливали

maksbaley
Ensign
Ensign
Posts: 4
Joined: 16 Sep 2015, 11:09

Re: Вроде всё готово, а каналы не грузит!

Postby maksbaley » 22 Nov 2015, 16:47

Все вопрос решен. просто у меня апишник внешний постоянно менялся при подключений. В конфиге нетворк прописал статичный и пошло кино.

User avatar
Eugene
Project Leader
Project Leader
Posts: 5988
Joined: 15 Apr 2013, 22:54
TV Model: LG 47LM960V, LG LB679V
Location: Санкт-Петербург
Has thanked: 36 times
Been thanked: 248 times
Flag: Russia
Contact:

Re: Вроде всё готово, а каналы не грузит!

Postby Eugene » 22 Nov 2015, 16:55

Видимо, все-таки айпишник внутренний, т.к. внешний на локальную udp proxy влиять не может. Да и выставить внешний IP в настройках сети вы никак не сможете.

maksbaley
Ensign
Ensign
Posts: 4
Joined: 16 Sep 2015, 11:09

Re: Вроде всё готово, а каналы не грузит!

Postby maksbaley » 23 Nov 2015, 13:21

Eugene wrote:Видимо, все-таки айпишник внутренний, т.к. внешний на локальную udp proxy влиять не может. Да и выставить внешний IP в настройках сети вы никак не сможете.

При запуске udpxy у меня выходила ошибка инвалид eth1 ip адрес. я добавил вот такой параметр config interface iptv
option proto 'static'
option ipaddr '176.10.10.10'
option netmask '255.0.0.0'
option ifname 'eth1'
Так все заработало

strelok1986`
Ensign
Ensign
Posts: 5
Joined: 29 Dec 2015, 11:48

Re: Вроде всё готово, а каналы не грузит!

Postby strelok1986` » 29 Dec 2015, 11:53

alexk wrote:Установил прошивку OpenWrt на роутер Tp-Link TL-WR941ND. Существует мануал как настроить?!
Спасибо!

Существует http://habrahabr.ru/post/138735/


Return to “Ошибки”

Who is online

Users browsing this forum: No registered users and 39 guests